This article applies to:
- Beat Buyers
- Beat Sellers
Overview
This article explains messaging limits, credits for messaging limits and what to do if you reach your messaging limit on the platform.
Common Causes
Free and Starter plan members have messaging limits. These monthly limits apply to both the sender and the recipient. Meaning that both parties must have available messaging credits to communicate.
Once you have reached your monthly limit, you will receive more credits in 30 days.
Please note that credits are not based on calendar months, so you will not automatically get more credits on the first of the month; it will be a month from when you used your last credit.
If you wish to have more messaging credits before that, you will need to upgrade to a Growth or Professional subscription plan, which has unlimited messaging.
Another issue could be that your message contains email addresses or links, which will prevent your message from being sent. Please be aware that you can always contact users by visiting the social links listed on their profile.
Related Articles:
How To Get In Contact With A Seller
How do I message someone? (Marketplace App)
How Do I Upgrade My Account?