This article applies to:
- Beat Sellers
- Beat Buyers
Overview
This article is to troubleshoot the issue of your session expiring. Please see the common causes and solutions below.
Common causes
We're sorry, sessions can expire for various valid reasons. Please see the common causes below.
- To protect your account
- Browser or device-related issues
- When we perform system updates to bring you new features. This is required in order to update the web/app versions.
Solutions
Please simply try to log back in. We also suggest clearing your browser's cache/cookies, closing your browser, and re-opening it before logging in. Also, we recommend disabling any ad block, antivirus, and browser plugins, if any may be interfering with your session.
Related Articles:
Why can't I log into my account?
What can I do if I am locked out of my account after too many failed login attempts?