This article applies to:
- Beat Buyers
Overview
In this article, we will troubleshoot the issue of not receiving a download link for a beat or sound kit after a purchase. This can be due to various reasons that we will outline below.
Common Causes
- Your transaction is stuck in "Pending", "Canceled", or "Voided".
- You are not checking the correct email address where your purchase was sent.
- You incorrectly entered your email address when checking out.
- You were not logged into your BeatStars account when making the purchase, so the transaction was completed as a guest purchase.
Solutions
- If you have a BeatStars account and were logged in when you made the purchase, you should be able to find your order in the "Purchased" section of your account. If you do not see the purchase in that section, or if your BeatStars invoice ID starts with "GUEST", it means you were not logged in when you completed the transaction, and the purchase was made as a guest. To download your purchased files as a guest, you will need to check your email inbox for an email receipt from BeatStars. This email will contain a link to download your files.
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If your transaction is stuck in "Pending", "Canceled", or "Voided", usually this indicates either an issue with your payment method, the producer's PayPal account, or an issue on PayPal's side. Files cannot be sent until PayPal confirms that all producers/merchants have received their portion of the funds successfully. If there is an issue with the transaction, the files cannot be sent. This is more common on beats with collaborators, because more producers are required to successfully receive their portion of the funds before the transaction is considered complete. If this happens, please contact PayPal Support for further assistance, as BeatStars is not the processor of the transaction and has limited information to help. PayPal should be able to push the transaction through or cancel it so you can try again.
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If your transaction is marked as "Completed", please check all of your email accounts for the transaction receipt. If you still do not see this email, please submit a ticket with your BeatStars invoice ID so we can look up the transaction. The BeatStars invoice ID will begin with BSGUEST_ PROGUEST_ PRO_ BS_ or similar.
Related Articles:
Where can I find my purchased orders?
Why are my PayPal transactions being voided, declined, or stuck in pending?